Pharos (Student Printing) MobilePrint Issues
Incident Report for WesternU
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 11:25 PDT
Investigating
We are experiencing issues with Pharos MobilePrint. You may be able to login and upload jobs, but they may not render. Investigating.
Posted Sep 19, 2022 - 08:49 PDT
This incident affected: Miscellaneous (Miscellaneous).