"TokenFactoryIFrame" Download Issue on O365 Outlook w/ Safari
Incident Report for WesternU
Resolved
Issue has been resolved per Microsoft. Internal testing confirms issue no longer present.

https://answers.microsoft.com/en-us/outlook_com/forum/all/tokenfactoryiframe/f4716303-ac2a-41d2-adb3-b164edfd083b
Posted May 11, 2022 - 07:39 PDT
Identified
We are aware of a known Microsoft bug that when you visit http://go.westernu.edu/mail on the Safari browser on macOS, every few seconds a file named "TokenFactoryIFrame" downloads. This is a bug on Microsoft's end. Some customers stated they saw a pop-up asking, "Do you want to allow downloads on "outlook.office.com"? with [Cancel] and [Allow]" options before this started and we have been able to replicate that.

This is not a virus or malware, but rather a bug that Microsoft will need to address. Our recommended workaround is to use Microsoft Edge, Google Chrome, or Mozilla FireFox until this issue is resolved by Microsoft.

https://answers.microsoft.com/en-us/outlook_com/forum/all/tokenfactoryiframe/f4716303-ac2a-41d2-adb3-b164edfd083b
Posted May 03, 2022 - 16:20 PDT
This incident affected: Microsoft 365 Services (Misc.).