Epic Printing Slowness
Incident Report for WesternU
Resolved
Internal testing indicates that this issue has been resolved.
Posted Jan 15, 2021 - 12:29 PST
Monitoring
The vendor (OCHIN) has provided confirmation that the slow printing from Epic issue is not yet resolved.
Posted Jan 15, 2021 - 08:56 PST
Identified
We have been notified by OCHIN that there are system-wide issues concerning printing slowness in Epic. OCHIN is currently investigating this matter.
Posted Jan 14, 2021 - 12:42 PST
This incident affected: Clinical Systems (EPIC).