Google Apps Certificate Issue

Incident Report for WesternU

Resolved

Certificate has been updated. Issue resolved.
Posted Jan 06, 2026 - 08:57 PST

Identified

We are ware of a certificate issue that is affecting the ability to login to the WesternU Google apps suite. We are actively working to resolve this as quickly as possible.
Posted Jan 06, 2026 - 08:20 PST
This incident affected: Miscellaneous (Miscellaneous).