my.westernu.edu Slowness

Incident Report for WesternU

Resolved

Performance of My.WesternU.edu is at expected levels.
Posted Jan 12, 2026 - 16:54 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 15:50 PST

Investigating

Some customers are experiencing slowness and some cards may not load on my.westernu.edu. This is a vendor related issue, and we are awaiting their investigation and updates.
Posted Jan 12, 2026 - 15:08 PST
This incident affected: Campus Services (My.WesternU.edu (previously YOU Portal)).