Slowness with EPIC
Incident Report for WesternU
Resolved
Confirming that the reported Epic slowness has been resolved.
Posted Apr 22, 2024 - 17:29 PDT
Monitoring
OCHIN has updated that "the root issue has been addressed".

We will be monitoring the issue to confirm the issue is resolved.
Posted Apr 22, 2024 - 10:22 PDT
Identified
We have received a report from the EPIC vendor, OCHIN, that the system is running slower than expected. Additional information will be provided when available.
Posted Apr 22, 2024 - 08:35 PDT
This incident affected: Clinical Systems (EPIC).