my.westernu.edu Issue
Incident Report for WesternU
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 16:39 PST
Monitoring
This was a vendor issue that has now been resolved. We will continue to monitor the situation, but access should be restored now.
Posted Feb 21, 2024 - 08:44 PST
Investigating
We are currently investigating this issue.
Posted Feb 21, 2024 - 08:12 PST
This incident affected: Campus Services (My.WesternU.edu (previously YOU Portal)).