911 Degraded Service

Incident Report for WesternU

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 12:28 PDT

Identified

We are currently experiencing issues with our 911 servers. You can still dial 911 in an emergency and will be connected to the appropriate local emergency services. However, your location and address information will not be automatically provided to the 911 operator.

If you need to call 911, please be prepared to provide your location and address to the operator.
Posted Sep 17, 2026 - 11:26 PDT
This incident affected: Campus Services (Telecom).