WesternU Web Site Inaccessible

Incident Report for WesternU

Resolved

WWW.WesternU.edu is accessible and stable.
Posted Jun 12, 2025 - 16:51 PDT

Monitoring

Cloudflare reports the issue has been resolved and this issue has been updated to Monitoring.
Posted Jun 12, 2025 - 15:00 PDT

Identified

The issue is related to the Cloudflare outage.

Here is the latest update from Cloudflare that is affecting the WesternU website:

"We are starting to see services recover. We still expect to see intermittent errors across the impacted services as systems handle retried and caches are filled."
Posted Jun 12, 2025 - 12:52 PDT

Investigating

WWW.WesternU.Edu is currently unavailable and the issue is being investigated.
Posted Jun 12, 2025 - 11:39 PDT
This incident affected: Campus Services (www.westernu.edu).