Epic - Reported Slowness

Incident Report for WesternU

Resolved

Ochin has reported that Epic functionality has been fully restored.
Posted Mar 30, 2026 - 15:39 PDT

Investigating

OCHIN is aware of the Epic slowness and is currently investigating this issue. We hope to have a resolution soon.
Posted Mar 30, 2026 - 14:00 PDT
This incident affected: Clinical Systems (EPIC).