Network Issue
Incident Report for WesternU
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 07:39 PDT
Investigating
We are investigating a network issue.
Posted Apr 24, 2024 - 07:30 PDT
This incident affected: University Networks (Pomona Campus, East Valley Clinic, Rancho Mirage).