Pomona Power Outage

Incident Report for WesternU

Resolved

Power has been restored to all affected buildings.
Posted Oct 14, 2025 - 09:55 PDT

Update

Per SoCal Edison, they are aware of the issue and an investigator is en route to the outage.
Posted Oct 14, 2025 - 08:38 PDT

Investigating

We have reports of power outages in NSC, VMC, and PCC.
Posted Oct 14, 2025 - 08:14 PDT
This incident affected: Campus Services (Electricity).