Pomona Power Outages

Incident Report for WesternU

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 13:24 PST

Monitoring

Power has been restored in all buildings. Please report any outages to ISS@westernu.edu.
Posted Nov 14, 2025 - 10:45 PST

Update

Confirming that the following buildings are currently without power: AAC, NSC, VMC, and PCC. The PCC is currently on a backup generator.
Posted Nov 14, 2025 - 10:31 PST

Investigating

We have reports of power outages in AAC and PCC.
Posted Nov 14, 2025 - 10:10 PST
This incident affected: Campus Services (Electricity).