Issues with Self-Service Banner 8 & My.WesternU.edu
Incident Report for WesternU
Resolved
Confirming both issues have been resolved.
Posted Apr 15, 2024 - 08:44 PDT
Identified
We are aware of an issue that is affecting Self-Service Banner 8 as well as some links on My.WesternU.edu. We believe this should be fixed in less than an hour.
Posted Apr 15, 2024 - 08:20 PDT
This incident affected: Campus Services (Self Service (Banweb), My.WesternU.edu (previously YOU Portal)).