support.westernu.edu Slowness

Incident Report for WesternU

Resolved

This incident was resolved by TeamDynamix around 12PM PT.
Posted Nov 06, 2025 - 14:16 PST

Update

TeamDynamix is acknowledged there is an issue and are investigating: https://status.teamdynamix.com/incidents/c6hr6gf8fddj
Posted Nov 06, 2025 - 10:49 PST

Investigating

We have observed that support.westernu.edu is loading very slowly. This is a hosted application and TeamDynamix's own status page has not provided any updates yet.
Posted Nov 06, 2025 - 10:44 PST
This incident affected: Third-Party Services (TeamDynamix (support.westernu.edu)).