Outlook Client Slowness/Locking Up
Incident Report for WesternU
Resolved
Closing this long-running incident out as there is nothing further to report or investigate. Most customers have seen improvements in speed and (lack of) lockups in the last few weeks. With that said, this is a hosted solution so we reliant on Microsoft's services/systems. If you have any specific/individual issues please contact TechSupport for further troubleshooting.
Posted Aug 24, 2022 - 15:34 PDT
Update
We are still monitoring this issue and still believe this is something on Microsoft's side, but we have internal reports of speeds being much better today. We will continue to monitor and collect data should this not be fully resolved.
Posted Aug 05, 2022 - 12:38 PDT
Monitoring
We are aware of reports of customers experiencing slowness and 5-10 second lockups in the full/desktop version of Outlook. Microsoft experienced a major service outage on July 20-21 and the internal belief is that these are lingering issues. At this time, we do not believe this is something we have the ability to resolve or troubleshoot as this is a hosted system but we will continue to monitor reports.
Posted Jul 27, 2022 - 11:37 PDT
This incident affected: Microsoft 365 Services (Misc.).