Banner & Related Systems Emergency Maintenance

Incident Report for WesternU

Resolved

The maintenance has concluded and all systems are operational.
Posted Aug 29, 2025 - 23:42 PDT

Identified

Banner and all related systems, including Banner 9, Self-Service Banner, MY Portal, Banner Document Manager (BDM), eProcurement, CashNet, and others are currently unavailable while we apply an emergency security patch.
Posted Aug 29, 2025 - 22:54 PDT
This incident affected: Administrative Services (Banner) and Campus Services (Self Service (Banweb), My.WesternU.edu (previously YOU Portal)).