Epic - Printing Issue

Incident Report for WesternU

Resolved

Epic printing has been confirmed.

Issue Resolved.
Posted Jul 10, 2026 - 10:02 PDT

Monitoring

OCHIN the developer of Epic has reported the following regarding the Epic Printing Issue.


Announcement to Users
OCHIN has confirmed that this issue is now resolved. If you are still experiencing printing failures, Web BLOB errors, or related issues, please restart Epic session and test again.

Who/what is affected?
Users printing and saving images to Web Blob
Posted Jul 09, 2026 - 16:14 PDT

Investigating

OCHIN the developer of Epic, has received reports of issues with printing and saving images to the Web BLOB server. OCHIN is currently investing this issue.

Who/what is affected?
Users printing and saving images to Web Blob
Posted Jul 09, 2026 - 14:11 PDT
This incident affected: Clinical Systems (EPIC).