Microsoft Office 365 Apps Issues

Incident Report for WesternU

Resolved

Microsoft has confirmed that the Microsoft Office 365 Apps suite issue is resolved and all services are restored.
Posted Oct 30, 2025 - 08:24 PDT

Update

An update has been provided by Microsoft:

"Our configuration deployment and traffic rebalancing is showing steady service health improvement. Some users may experience residual impact until availability fully recovers. We're monitoring for an extended period to ensure service health is restored as expected."

The next update from Microsoft is expected Wednesday, October 29, 2025 at 6:00 PM PDT
Posted Oct 29, 2025 - 16:54 PDT

Identified

An update has been provided by Microsoft:

"We've completed the deployment of a healthy configuration and we're continuing our active traffic balancing efforts as well as monitoring corresponding service telemetry to ensure widespread recovery."

The next update from Microsoft is expected Wednesday, October 29, 2025 at 4:30 PM PDT
Posted Oct 29, 2025 - 13:26 PDT

Investigating

Microsoft is reporting various issues (access and crashing) across the Office 365 office suite apps including but not limited to:

Microsoft Teams
Microsoft Outlook
Microsoft SharePoint

These issues may also affect the mobile app versions.

This issue resolution is outside of WesternU control and we are waiting for updates from Microsoft.
Posted Oct 29, 2025 - 10:43 PDT
This incident affected: Microsoft 365 Services (Sharepoint Online, Outlook Online, Teams, Misc.).