Canvas Issue/Outage

Incident Report for WesternU

Resolved

WesternU Canvas access has been restored.
Posted May 11, 2026 - 09:51 PDT

Monitoring

Instructure has indicated that Canvas has been restored and available for WesternU. WesternU considers this event dynamic and are closely monitoring the situation.
Posted May 08, 2026 - 09:01 PDT

Identified

Further details are available at the status page for Canvas: https://status.instructure.com/
Posted May 07, 2026 - 17:05 PDT

Investigating

Canvas is currently down, Online Education has contacted support and engineers are working on the issues.
Posted May 07, 2026 - 13:49 PDT
This incident affected: Academic Services (Canvas).