My.WesternU.edu Cards Interruption

Incident Report for WesternU

Resolved

The vendor has resolved this incident and we have confirmed everything is working as well.
Posted Dec 12, 2025 - 09:13 PST

Monitoring

Ellucian has provided an update:

Ellucian engineers worked with their vendor partners to identify the issue impacting Experience cards not appearing in the dashboard for some users. Small improvements have been seen, they continue to work on incremental improvements and they will continue to closely monitor overnight.
Posted Dec 11, 2025 - 14:35 PST

Update

Ellucian has provided an update:

Ellucian engineers continue working to resolve the issue where Experience cards do not appear in the dashboard for some users. They are working with our vendor partners and will continue to provide updates.
Posted Dec 11, 2025 - 12:49 PST

Investigating

Ellucian Support has provided the following notification that affects My.WesternU.edu.

Some users have reported intermittent issues with some cards not showing in the dashboard. Ellucian engineering teams are engaged and will provide updates shortly.
Posted Dec 11, 2025 - 09:42 PST
This incident affected: Campus Services (My.WesternU.edu (previously YOU Portal)).