Banner Access Issue

Incident Report for WesternU

Resolved

Access to Banner has been restored.
Posted May 01, 2026 - 14:59 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 13:35 PDT

Identified

IT is currently working to resolve access to Banner.

Users may receive the following error when attempting to use Banner "pom-artemis.westernu.edu took too long to respond"
Posted May 01, 2026 - 13:18 PDT
This incident affected: Administrative Services (Banner).