TechSupport Phone Issue

Incident Report for WesternU

Resolved

A fix has been implemented and all calls into TechSupport (909) 469-5432 are no longer hearing static.
Posted Nov 30, 2023 - 10:44 PST

Investigating

Currently all calls into TechSupport (909) 469-5432 are connecting but callers are hearing static on the line.

The issue is being investigated. Please continue to email TechSupport@westernu.edu or submit requests at Supoort.WesternU.edu. d
Posted Nov 30, 2023 - 10:33 PST
This incident affected: Miscellaneous (Miscellaneous).