ExamSoft Legacy Loading and Delay Issues

Incident Report for WesternU

Resolved

ExamSoft has provided the following update:

This issue has been resolved. All functions to the legacy portal have been restored.
Posted Dec 08, 2025 - 09:57 PST

Investigating

ExamSoft has provided the following Issue:

ExamSoft reports that some users are having issues loading or logging into the Legacy Portal. Their team is actively investigating and working to restore normal service as quickly as possible.
Posted Dec 08, 2025 - 09:25 PST
This incident affected: Third-Party Services (ExamSoft).