General Slowness / ISP Issues

Incident Report for WesternU

Resolved

This incident has been resolved. Network performance and authentication services returned to normal operation late yesterday evening. We continued to monitor the environment throughout the morning and have not observed any further widespread issues. Based on our investigation, the incident appears to have been related to disruptions affecting external Internet Service Providers (ISPs) and Microsoft-hosted services outside of the University's network and administrative control.
Posted Jul 08, 2026 - 13:15 PDT

Monitoring

We have noticed a significant speed increase this morning and believe some of the ISP issue outside of our network have stopped, but we will continue to monitor. We have observed a significant improvement in network performance this morning and believe the Internet Service Provider (ISP) issues affecting connectivity outside of the University's network have largely subsided. We will continue to monitor the situation closely and provide additional updates if conditions change.
Posted Jul 08, 2026 - 07:30 PDT

Update

We are aware of intermittent connectivity and performance issues affecting some online services. At this time, the issue appears to be related to disruptions impacting one or more Internet Service Providers (ISPs) and does not appear to originate within the University's internal network. As a result, some hosted services outside of the University's network and control may also experience degraded performance or intermittent connectivity. We are actively monitoring the situation and will provide additional updates as more information becomes available.
Posted Jul 07, 2026 - 14:05 PDT

Identified

After further investigation, it appears that the cause of the slowness within Epic is occurring at a connection point between WesternU and OCHIN (our Epic vendor).

IT will continue to monitor the situation and provide updates as they become available.
Posted Jul 07, 2026 - 11:18 PDT

Investigating

WesternU IT is currently investigating reports of slowness within Epic
Posted Jul 07, 2026 - 09:39 PDT
This incident affected: Clinical Systems (EPIC) and Miscellaneous (Miscellaneous).