My.WesternU.edu
Incident Report for WesternU
Resolved
My.WesternU.edu is not fully functional. All back-end issues resolved.
Posted Feb 29, 2024 - 08:49 PST
Update
Currently working with the Vendor to resolve the last remaining issue for My.WesternU.edu.

Some students may experience issues with accessing their Student Course Card at My.WesternU.edu.

WesternU IT does not have an estimated time of resolution but will update as soon as possible.
Posted Feb 28, 2024 - 10:24 PST
Monitoring
My.WesternU.edu is still experiencing back-end issues that are currently being investigated.

This issue has been moved to Monitoring until the back-end issues are resolved.
Posted Feb 27, 2024 - 16:49 PST
Identified
Some users may receive the following error when trying to access My.WesternU.edu "a temporary server problem. Some cards and information may not be visible at this time."

IT is currently on resolving the issue but no ETA of resolution.
Posted Feb 26, 2024 - 14:29 PST
This incident affected: Campus Services (My.WesternU.edu (previously YOU Portal)).