Dragon Medical One - Epic
Incident Report for WesternU
Resolved
Dragon Medical One is now confirmed working within Epic.
Posted Jul 19, 2024 - 16:53 PDT
Identified
OCHIN (Epic) has been informed that Microsoft has identified a process to address the CrowdStrike defect found in a single content update for Windows hosts. Nuance (Dragon Medical One) is working as quickly as possible to implement this fix; however, it will take time to complete. In the meantime, Ochin recommends providers continue using downtime procedures until further notice.
Posted Jul 19, 2024 - 11:55 PDT
This incident affected: Clinical Systems (EPIC).