"Cloudflare, a global provider of internet services, has confirmed that the technical issues experienced earlier today are now resolved and Elentra service is now fully operational."
Posted Nov 18, 2025 - 11:40 PST
Identified
Elentra has reported the following regarding theirserver disruption:
As of earlier today, some users may have experienced intermittent challenges accessing Elentra.
Cloudflare, a global provider of internet services, is currently experiencing a technical issue that is affecting services across the Internet, including Elentra.
• What is happening: Users may find that Elentra is intermittently unavailable. • Status: Cloudflare has identified the issue and their team is actively working to resolve it.
Elentra will provide an update as soon as we have confirmation that the issues have been resolved.
Posted Nov 18, 2025 - 08:25 PST
This incident affected: Academic Services (Elentra).