Microsoft Teams - Files Tab Content Issue
Incident Report for WesternU
Resolved
Microsoft has resolved this issue.

Details from Microsoft:

Title: Users' file libraries weren't refreshing when navigating to another library within the Files tab in Microsoft Teams

User impact: Users' file libraries weren't refreshing when navigating to another library within the Files tab in Microsoft Teams.

More info: This issue specifically impacted scenarios in which users were attempting to access multiple file libraries via the Files tab in Microsoft Teams. While the initial attempt to access a file library succeeded, when affected users attempted to navigate to a subsequent file library, they were again presented with the initially accessed library.

While we were focused on remediation, impacted users could bypass the impact by selecting the menu marked by a down arrow to the right of the "Files" menu at the top of the Files tab, then selecting "Reload Tab" to manually reload the affected library.

Current status: The cache has cleared by itself and we've confirmed that the issue is now resolved.

Scope of impact: Impact was specific to some users who were served through the affected infrastructure.

Start time: Sunday, March 26, 2023, 11:25 PM (3/27/2023, 6:25 AM UTC)

End time: Monday, March 27, 2023, 11:26 PM (3/28/2023, 6:26 AM UTC)

Root cause: A recent change to a component of Microsoft Teams infrastructure, responsible for delivering Files tab contents, introduced a code issue that redirected requests to a cached file library, resulting in impact.

Next steps:
- We're reviewing our service update and changes procedures to prevent this issue from happening again.

This is the final update for the event.
Posted Mar 29, 2023 - 08:05 PDT
Update
Microsoft has identified the issue and root cause. They anticipate the issue will be fixed early Wednesday morning.


Details from Microsoft:

Title: Some users' file libraries aren't refreshing when navigating to another library within the Files tab in Microsoft Teams

User impact: Users' file libraries aren't refreshing when navigating to another library within the Files tab in Microsoft Teams.

More info: This issue specifically impacts scenarios in which users are attempting to access multiple file libraries via the Files tab in Microsoft Teams. While the initial attempt to access a file library succeeds, when affected users attempt to navigate to a subsequent file library, they're again presented with the initially accessed library.

While we're focused on remediation, impacted users can bypass the impact by selecting the menu marked by a down arrow to the right of the "Files" menu at the top of the Files tab, then selecting "Reload Tab" to manually reload the affected library.

Current status: We've received confirmation that the fix successfully addresses the issue, and impact is remediated after users manually clear their cache. We expect the cache will clear by itself and no further manual actions will need to be taken to experience remediation by our next communications update.

Scope of impact: Impact is specific to some users who are served through the affected infrastructure.

Start time: Monday, March 27, 2023, 2:02 PM (9:02 PM UTC)

Estimated time to resolve: We anticipate the cache will be cleared and the issue will be fully resolved by Wednesday, March 29, 2023, 4:00 AM (11:00 AM UTC)
.

Root cause: A recent change to a component of Microsoft Teams infrastructure, responsible for delivering Files tab contents, introduced a code issue that's redirecting requests to a cached file library, resulting in impact.
Posted Mar 28, 2023 - 14:46 PDT
Identified
We have received notification from a few customers that the Files tab on some Microsoft Teams channels/teams is not properly showing up. This has manifested itself in such ways where the contents from one team/channel (that you already have access to) appears in another team/channel. Customers have had some success with fully closing out Teams and re-opening and/or trying to update Teams.

Microsoft has released an advisory for a rendering issue that we believe to be related. We are keeping an eye on that advisory and will provide relevant updates when available.

Microsoft Service Health Advisory: TM533773
Posted Mar 27, 2023 - 16:04 PDT
This incident affected: Microsoft 365 Services (Teams).