Elixir/eProcurement Down

Incident Report for WesternU

Resolved

Elixir / eProcurement is now operational and accessible.
Posted Oct 30, 2025 - 11:25 PDT

Investigating

ELIXIR / eProcurement is currently unavailable.

Updates will be provided as soon as they discovered.
Posted Oct 30, 2025 - 09:09 PDT
This incident affected: Miscellaneous (Miscellaneous) and Administrative Services (Misc.).