ADFS / MFA / SSO Login Issues
Incident Report for WesternU
Resolved
This issue is technically not resolved, but the problematic server has been removed from production. Two new servers have been brought up to test and the issue has re-presented itself each time. For now, the problem is resolved in the sense that no customers are affected, but further follow-up is required with Microsoft (actively working with them) to get this resolved long term. Should this issue begin affecting customers again we will open a new incident.
Posted Aug 02, 2022 - 16:29 PDT
Update
No reports of new issues today after disabling the affected server. This problem has not been solved, but it has been temporarily removed. Services were operational for our community today. We will provide another update when available.
Posted Jul 26, 2022 - 17:20 PDT
Update
Troubleshooting continues, but root cause has not yet been determined. We have opened a case with Microsoft. For now, we have completely disabled the server causing problems. It may be necessary to briefly re-enable the server to help identify the problem.
Posted Jul 25, 2022 - 22:36 PDT
Update
We are continuing to see issues with applications and services tied to Single Sign-On (SSO), Active Directory Federated Services (ADFS), and Multi-factor Authentication (MFA). We are actively troubleshooting these issues.
Posted Jul 25, 2022 - 16:15 PDT
Update
We are still trying to determine the root cause of these issues, but we believe we have identified a single ADFS server causing the problems. This single server has been removed from production and the problems have subsided for now, however, this leaves us with no redundancy should something else go down. We are continuing to troubleshoot the issue, but you *SHOULD* NOT have login problems while this server is offline.
Posted Jul 25, 2022 - 14:53 PDT
Investigating
We are expanding this issue to include other services that use ADFS and MFA as we believe this may be a larger issue. We are seeing customers having issues with logging into a variety of applications that require MFA.
Posted Jul 25, 2022 - 12:02 PDT
Monitoring
Internal testing and customer feedback indicate that the web version is working again. No changes made our end, so this is assumed an issue on ADP's side. We will continue to monitor the situation and close out later today if no additional problems.
Posted Jul 25, 2022 - 09:29 PDT
Investigating
Customers reporting issues logging into ADP via the web. Recommend using the mobile app until resolved.
Posted Jul 25, 2022 - 07:54 PDT
This incident affected: Microsoft 365 Services (Active Directory Federated Services (Single Sign-On)), Administrative Services (bswift, ADP), and University Networks (VPN - GlobalProtect).