Outlook Connection Issue

Incident Report for WesternU

Resolved

Microsoft has confirmed that access to Outlook has been restored.
Posted Jul 10, 2025 - 14:46 PDT

Identified

Microsoft is reporting the following issue:

"Users attempting to access their Exchange Online mailbox using any connection methods may be impacted."

The connection issues seem sporadic. Microsoft is expected to provide an update July 10, 2025 at 9:30 AM PDT
Posted Jul 10, 2025 - 08:34 PDT
This incident affected: Microsoft 365 Services (Outlook Online).