TDX Slowness

Incident Report for WesternU

Resolved

We have not had any reported issues or witnessed any issues this since it was reported fixed yesterday. Issue resolved.
Posted Jun 03, 2025 - 09:53 PDT

Monitoring

TDX has indicated that they have rolled back an update and performance has been restored. This is partially accurate as TDNext seems to load quickly, but we believe there may be a backlog of requests and tickets process and we're receiving emails that were created two hours earlier. We will continue to monitor.
Posted Jun 02, 2025 - 12:52 PDT

Identified

TDX Update: "TeamDynamix experienced performance issues today following the release of some important new capabilities over the weekend.

Due to a technical concern, we have decided to roll back the new version of the service for the US-based customers who received it this weekend. *This rollback only impacts the group of US-based customers that went live on the new UX in this specific wave.*

We successfully rolled out the new UX to 30% of customers prior to this weekend, and these performance issues were not previously seen.

We apologize for the inconvenience, and we will be in close contact on next steps."

----------------------------

WesternU Customers: Please be mindful that the technician side support.westernu.edu will not load for most of us. If you submitted a in the last 24 hours, please understand that it likely has not been seen yet. If you have an urgent matter, we recommend contacting by phone until this is resolved.
Posted Jun 02, 2025 - 10:17 PDT

Update

TDX has been providing hourly updates, here are the last two:

9AM PT Update:
"Thank you for your continued patience as investigation continues.

TeamDynamix Engineering and Infrastructure teams continue to work to develop the fix for the Work Management degradation. We'll provide updates as soon as possible."

8AM PT Update:
"Thank you for your continued patience as investigation continues. We are nearing a fix for the issue that has caused this degradation.

TeamDynamix Engineering and Infrastructure teams continue work to develop the fix for this Work Management degradation. We'll provide updates as soon as possible."
Posted Jun 02, 2025 - 09:05 PDT

Investigating

Per TeamDynamix Engineering:

“We are actively investigating reports of performance degradation this morning. This seems to mostly affect the Work Management (Users: formerly TDNext) interface at this time.”
Posted Jun 02, 2025 - 07:06 PDT
This incident affected: Third-Party Services (TeamDynamix (support.westernu.edu)).