Oliver Station Internet Issue

Incident Report for WesternU

Resolved

ISP has confirmed everything is clear and we have not see any issues since. Issue resolved.
Posted Dec 24, 2025 - 12:51 PST

Monitoring

The ISP has resolved an issue and connectivity has returned to Oliver Station. We will continue to monitor but all services such as a phones and internet connections should be back.
Posted Dec 24, 2025 - 10:32 PST

Investigating

Our Internet Service Provider for Oliver Station in Portland is currently experiencing issues. There is currently no internet to the clinic, thus no phone or computer connectivity. We have reported the issue to the ISP and will provide updates when available.
Posted Dec 24, 2025 - 09:52 PST
This incident affected: University Networks (Oliver Station).