eTranscript
Incident Report for WesternU
Resolved
eTranscript services have been restored.
Posted Feb 23, 2024 - 13:49 PST
Investigating
An issue was reported with eTransript, which is a service used to provide transcripts to students/alumni and used in conjunction with the Office of the Registrar. The issue seems to be software related and we will be working with the vendor to find a resolution.
Posted Feb 23, 2024 - 09:38 PST
This incident affected: Administrative Services (Misc.).