Microsoft Outage
Incident Report for WesternU
Resolved
This incident has been resolved. This outage had little to no impact on WesternU.
Posted Jul 19, 2024 - 20:50 PDT
Monitoring
Microsoft has experienced a significant outage due to a third-party vendor (CrowdStrike) applying a system update. This caused massive outages and disruptions around the country and globe. Thankfully, the impact to WesternU has been minimal as the majority of the issues appear to be limited to central and east coast servers in the United States. Some services may be slower than usual or have unexpected oddities as Microsoft continues to recover. WesternU IT will continue to monitor our services and report anything noteworthy on status.westernu.edu.
Posted Jul 19, 2024 - 08:40 PDT
This incident affected: Microsoft 365 Services (Misc.).