Frontier / eeros Router GlobalProtect Issue

Incident Report for WesternU

Resolved

TechSupport has confirmed that previously reported GlobalProtect connection issues are working today, 8/1.

It appears that Frontier / eeros made changes overnight and GlobalProtect is currently working.

Some users report receiving a pop-up message stating" GlobalProtect needed to change the connection type due to current network conditions. You may notice a change in the quality of your connections"

This message does not cause any issues with connecting to GlobalProtect.
Posted Aug 01, 2025 - 10:06 PDT

Investigating

TechSupport has been receiving reports of GlobalProtect connection issues.

Reports are from users with Frontier and their provided eeros router.

This appears to be an issue with the eeros hardware. IT is currently investigating.
Posted Jul 31, 2025 - 16:19 PDT
This incident affected: University Networks (VPN - GlobalProtect).